Message d’erreur php / tâche cron / php -f .. PHP Deprecated .. line 0 line 1 ..safe_mode’ is deprecated

Lorsque vous lancez une tache cron ou en shell php -f ..   Ce message d’erreur peut apparaître :

1) PHP Deprecated:  Comments starting with ‘#’ are deprecated in /etc/php5/cli/conf.d/imap.ini on line 1 in Unknown on line 0
PHP Deprecated:  Comments starting with ‘#’ are deprecated in /etc/php5/cli/conf.d/mcrypt.ini on line 1 in Unknown on line 0
2) PHP Warning:  Directive ‘safe_mode’ is deprecated in PHP 5.3 and greater in Unknown on line 0
Log cleaned

____________________________________________

1) Correctif à apporter :

il suffit de changer dans les fichiers consernés le # par un ;

ouvrir avec un éditeur de texte :

/etc/php5/cli/conf.d/imap.ini
/etc/php5/cli/conf.d/mcrypt.ini

____________________________________________

2) Correctif à apporter :

PHP Warning:  Directive ‘safe_mode’ is deprecated in PHP 5.3 and greater in Unknown on line 0

safe_mode n’est plus utilisé dans php 5.3 et +

Ouvrir le Fichier php.ini dans un éditeur de texte

/etc/php5/cli

chercher : safe_mode = On

remplacé par safe_mode = Off

Puis redemarrer votre service apache

service apache2 stop
service appache2 start

et voila🙂

, , , , , , , , , , , , , , , , , ,

  1. #1 par Ante prima le 12 mars 2015 - 16:03

    Bonjour, après avoir fait migrer mon site d’une version PHP 5.2 à 5.5, j’ai reçu ce message d’erreur en voulant me connecter au backend : Comments starting with ‘#’ are deprecated in /home/anteprim/Urano/etc/ante-prima_ciclope.ini on line 9.
    J’ai suivi la marche indiquée [remplacer les occurrences de # par ; ] pour corriger le script ante_prima_ciclope.ini mais si maintenant j’arrive à accéder à mon backend, je ne peux rien y faire et l’affichage est très bizarre.
    Qu’est ce que je peux faire ? Merci d’avance.

    • #2 par ek0892 le 12 mars 2015 - 21:44

      vous devez être sur que votre site fonctionne en php 5.5 avant de migrer votre serveur. beaucoup de solution doivent être mis à jour, ce le cas par exemple de magento 1.6 qui fonctionne en 5.3 max , il faut magento 1.9 pour un serveur php 5.5

  2. #3 par Ante prima le 13 mars 2015 - 11:07

    C’est bien ce que je craignais… est-ce qu’une fois l’upgrade fait on peut downgrader ?

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :